Results 51 to 57 of 57

Thread: Separating motor from pump issue

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Separating motor from pump issue

    Greetings All!,
    New here so, I hope I don't screw up too badly.

    I am trying to help out a destitute friend with their residential well pump and maybe you can help me help them....


    They have (HAD!) 2 above ground pumps which one was hit by lightning and the other is "frozen" (locked up completely)......I have attempted to separate the motor from the pump and have removed the entire unit from the well completely.....I am having GREAT difficulty separating the pump motor from the pump housing with the impeller and bolt being removed and all bolts loosened or removed....How is this accomplished?



    MOTOR MODEL # CET50ABN
    MOTOR MODEL #C48L2FC4 SER# 6G81 FRAME 48Y


    MSE-6 MODEL 1M87H

    Attached Images Attached Images

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Issue with starite pump
    By Mutant in forum Pumps in general
    Replies: 15
    Last Post: 01-06-2014, 12:05 PM
  2. Pump Issue or Well Issue
    By bankerman in forum Introduce yourself
    Replies: 13
    Last Post: 08-29-2012, 08:59 PM
  3. Jet Pump Issue?
    By amkazen in forum Pumps in general
    Replies: 1
    Last Post: 01-04-2012, 02:06 PM
  4. Pump Issue (continued)
    By Diesel984 in forum Pumps in general
    Replies: 5
    Last Post: 07-29-2010, 08:59 PM
  5. Pump Issue!
    By Diesel984 in forum Pumps in general
    Replies: 50
    Last Post: 07-27-2010, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •