well was installed 4 years ago very shallow maybe 30' - 40' if I remember correct. The well driller didn't respond to calls to come start the pump up when we got power. The pressure switch was not set, the tank had too little pressure in it and was a mess. I got help here setting the pressure switch & getting the tank pressure correct. However there was also tons of sand etc. I found out he was not licensed and finally when I talked to the head well insp for the state he came out and blew sand out of the pump..... Didn't even let me know he was coming I just saw him speeding out of the drive.. other than the fact that every time the water has to be shut off or we loose power it stirs up the sand in the line from the well to the house (400') it's mostly operated ok.

Fast forward to this weekend I had to go to N Ga and on the drive home my wife informs me the water died. Get home and the pump is dead, power, pressure switch & cap. are all good. motor is humming trying to start. I can't read anything off the pump but I'm 99% sure it's a Utilitech 0.5-HP Jet Pump ...now the piping also has me baffled ....the well casing is only 3" it has a 1" drop pipe come through a 3" cap with a hole drilled in it. to a 90 then a check valve then the pump. (I'm assuming there is also a check valve at the bottom, wouldn't there have to be? what purpose would the 2nd valve serve? ) the check valve is so close to the pump that there was no room to cut pipe and have room to reconnect it so I unscrewed the pump from the piping.

Looking for recommendations on a pump and being disabled on a fixed SMALL income $$$ are an issue .....but also questioning the piping any suggestions???

thanks