Results 1 to 4 of 4

Thread: Jet pump loss of pressure

  1. #1

    Jet pump loss of pressure

    I have a problem with a sears jet pump. When the valve is fully open and flow is maximum the pressure drops slowly to about 20 psi and then abruptly drops to zero. When I shut the valve the pressure will return to normal operation. It seems that teh pump loses prime and then recovers when I close the valve. Can any one help with this problem?

  2. #2
    Pump guy speedbump's Avatar
    Join Date
    Jun 2005
    Location
    Murphy, NC. USA.
    Posts
    11,786
    Your simply letting out more water than the pump/well can produce, therefore no pressure. You probably have a bladder tank with 20 lbs of air in it and that's why it drops from 20 to zero abruptly.

    Products and Pricing

  3. #3
    There is an adjustment on the pump which was tampered with and this adjustment, I think, controls the amount of water picked up by the pump. Could this be the problem? Do you have any info regarding how this adjustment is set up?

  4. #4
    Pump guy speedbump's Avatar
    Join Date
    Jun 2005
    Location
    Murphy, NC. USA.
    Posts
    11,786
    If it's a plastic looking screw with a flat screw slot in it, it's called a backpressure control. It's a pretty poor excuse for a backpressure control, but that's what it is. It is only needed for priming the pump on a deep well system. If your pump is shallow well, then just open it up all the way.

    Products and Pricing

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •